www.detachedsolutions.com
Detached Solutions Title


The MirageOS User's Manual


Program Manager Usage :  Function Bar Aspects


The Function Bar is an important aspect of MirageOS where the user carries out most of the major processes that change program and folder properties. It allows the user to easily access different functions of the shell by resembling the menu system of the TI-85/TI-86 calculators, where five boxes with words are shown at the bottom of the screen. The Function Keys at the top of the calculator control the commands on those menus, either executing the command or navigating the user through other menus.

The Function Bar is only available to the Program Manager interface, not any other GUI, and it is accessible by pressing the "X,T,0,n" key. Activating the Function Bar will cause it to scroll onto the bottom of the screen, overlapping the area where the program and folder descriptions are initially shown. It will scroll on and off the screen whenever you activate/deactivate it, and when switching between menus. The Main Function Bar that appears first contains a few functions, and its File menu branches off to other menus of specific functions. Each of these will be explained in detail further down.


Function Bar Menu Layout:

Below is chart that displays the layout and order of the various Function Bar menus. You will see arrows coming from particular functions which cause the next menu below it to be loaded. The "Back" buttons will return you to the previous menu.


Brief Function Descriptions:

Here is a list of every function on all the menus of the Function Bar. Brief descriptions for these are given here, and further down you will find each function topic explained in detail. You will also see screen shots that go along with those topics.

  FILE - Takes the user to the Folder or Program File Menus. 
  LINK - Transfers the current program to another calculator.
  MEM  - Displays the amount of Free RAM and ROM on the calc.
  PGUP - Shifts the cursor up five programs or folders.      
  PGDN - Shifts the cursor down five programs or folders.    

  NEW  - Creates a New Folder (Only Ten Max including MAIN). 
  NAME - Renames the current Folder to another custom name.  
  DEL  - Deletes the current Folder in the list of entries.  
  SORT - Takes the user to the menu of Folder Sort Methods.  
  BACK - Returns to the Previous Menu: Main Function Bar.    

  MOV  - Moves the current Program to another user Folder.   
  NAME - Renames the current Program to another custom name. 
  DEL  - Deletes the current Program in the list of entries. 
  INFO - Takes the user to the menu of Program Information.  
  BACK - Returns to the Previous Menu: Main Function Bar.    

  NAME - Resorts the current Folder's program list by Name.  
  DES  - Resorts the current Folder's program list by Desc.  
  SIZE - Resorts the current Folder's program list by Size.  
  TYPE - Resorts the current Folder's program list by Type.  
  BACK - Returns to the Previous Menu: Folder File Menu.     

  ARCH - Archives/Unarchives current Program from FlashROM.  
  HIDE - Hides/Unhides current Program from the TIOS/shell.  
  LOCK - Edit-Locks/Unlocks current Program from the TIOS.   
  ALL  - Moves All Programs in current Folder to another.    
  BACK - Returns to the Previous Menu: Program File Menu.    
Transferring Programs:

   
The LINK function allows the user to send the current selected Program over the Link cable for another calculator to receive. This function lets you transfer any MirageOS-compatible program (MirageOS, ION, TI-82, & BASIC) to another TI-83+, TI-83, or TI-82. Do not attempt to run a MirageOS or ION program on a TI-82/83, however, sending an 82 program will work on an 82. The BASIC programs for the TI-83+ will most likely work on a TI-83 unless they use abnormal tokens or characters. We do not garuntee that all programs you transfer to another calculator will work by this linking method. If the Link cable is not connected, or removed in the transferring process, or ON is pressed, then MirageOS will output an "Error In Transmission" message to the user. Folders cannot be sent from MirageOS, and will do nothing if you press the Link function key when selecting a Folder.

Free RAM/ROM Display:

   
The MEM function allows the user to view the amount of FreeRAM and FreeROM that their calculator has, without having to exit the shell, and goto the Memory menu of the TI-OS to check this. The values displayed should match the ones shown on the TI-OS Mem screen in most cases, but let us know if you see it showing different values. The FreeRAM value is right-aligned within 5 digits since the maximum amount of FreeRAM is approximately 24 KB. The FreeROM value is right-aligned within 6 digits since that value can be approximately 160 KB at maximum. Some programs may not run because there is not enough FreeRAM existing for them to execute, and some programs may not be archived if there is not enough FreeROM left. You can check these two values from this Mem function in those cases, rather than having to leave the shell to check, and then delete or unarchive programs accordingly.

Paging Up and Down:

   
The Program Manager has a list of all Folder and Program entries that may eventually get quite long once you create many folders and load your calculator with many programs. In order to more quickly progress up and down through the list when searching for a Program or Folder, you can use the Page Up and Page Down functions labeled PGUP and PGDN respectively. If the cursor is not at the top or bottom of the current viewable list of entries, then pressing these two functions for the first time will shift the cursor there. Once the cursor is located at the top or bottom of the viewable area, then choosing these functions will shift the list of entries up or down by five entries.

Creating New Folders:

   
The function labeled NEW in the Folders File Menu is where the user can create new custom folders in MirageOS. These folders are optional to have and use to organize programs into, and they can have custom names that are 8 letters at maximum. The names of your folders can later be renamed using another function. MAIN is the default folder in MirageOS where all programs go when they are initially loaded onto the calculator, and the user can move those programs into other folders they have created. The maximum number of folders you can have at once is 10, including the MAIN folder which can't be deleted from the system. Creating new folders lets the user better organize the programs on their calculator, so that they all aren't clumped together in MAIN, but are arranged into various categories.

Moving Single Programs:

   
The function named MOV allows the user to move the current selected Program to another folder of choice. This function allows users to move their programs around among the custom-named folders, where a person may want all games in one folder, all utilities in another folder, etc. After choosing MOV from the Function Bar, MirageOS will close all folders and tell you to select the folder you want to send the selected program to. After the program is moved, MirageOS will refresh and open the selected folder, showing that the program now exists there. You have the ability to move any program in MirageOS to any other user folder, and to manually move many programs at once, use the ALL function from the Programs Info menu.

Renaming Programs/Folders:

   
Programs and Folders can be Renamed with custom names by using the NAME function from the Program and Folder File Menus. Choosing this function will prompt the user for a new name on the command line where the Function Bar is located. The user will then be able to Type the name of the new name they want for the currently selected program/folder. Each key on the keypad will output its uppercase letter character, and to output numbers you must hold the ON key and then type one of the numbers. You should press Enter when you are done inputting the new name of the program/folder, or the command will terminate after inputting eight characters which is the maximum. The names of programs and folders must be at least one character long, and the first character cannot be a number or other character, but only a letter. MirageOS will reject names that have numbers as the first character and will have you input another name in. The Clear Key erases the line of characters while you are inputting them, and the Left key deletes one character and backs up to the previous position.

Deleting Programs/Folders:

   
The DEL function on both the Folder and Program File Menus lets you delete the current selected Folder or Program respectively. If you have the "Confirm Deletions" option turned On from the Main Options Menu, then MirageOS will display a message to the user asking them if they want to delete that Folder or Program. Press Y for Yes, and N for No at that message. With the option turned Off, the shell will not prompt this message and proceed to delete the current selected Folder or Program from the list, and then refresh the Program Manager with its entry removed.

Sorting Folders:

   
The four functions on the Sort Menu let you resort the current selected Folder by that particular Sort Method. NAME rearranges the Programs in the current Folder where their File Names are in order, alphabetically. DES orders the programs where their Descriptions are sorted alphabetically. SIZE puts the programs in order accordingly to their sizes, from largest to smallest. TYPE organizes the programs in the current folder by putting MirageOS-specific programs first, ION programs second, TI-82 programs third, and BASIC programs fourth. When Folders are created, they start out in 'Sort By Name' by default, and the user can change the sort method of each folder according to preference. There is an option that controls whether or not folders are sorted automatically at startup, and if that is turned off, you must choose one of these functions to manually sort a folder again.

Alter Program Aspects:

   
From the Programs Info Menu, the user has the ability to alter the Archived, Hidden, and Edit-Protected states of programs. When you press ARCH, the current selected program will become Archived into FlashROM if it was previously unarchived and in RAM, and vice versa. Pressing HIDE on a program that is not Hidden will cause it to become Hidden from the TI-OS, where it doesn't show up in the PRGM menu, and Hidden from MirageOS if the particular option is set for that. Pressing LOCK will swap the state of the current program from being Edit-Protected or not. This means the program will not be shown from the EDIT menu if it is Locked, and if it is Unlocked it can be viewed in the Basic Editor of the TI-OS.

Moving All Programs:

   
The ALL function allows the user to move All the programs in the current Folder to another folder, and it is meant so that the user doesn't have to use the MOV function on many single programs. Since this Function Bar item is located within the Program Info Menu, the cursor will be currently on a Program, but this function will apply to the whole folder of programs. After choosing this function, MirageOS will close all folders and will tell the user to select another folder they want to move all the programs to. Since this function is notated by the word ALL, it may not be too clear what it does, so MirageOS prompts the user with a message to "Move All In Folder?", and they should press Y or N accordingly. After moving all programs, the Program Manager will refresh with the changes, and the selected folder will be opened.


Copyright © 2000-2019  Detached Solutions
Last Modified: 2002-09-03 22:05:44 GMT